Wacom Pen Eraser side button doesn't work with WinTab?

Type of device: Graphics Tablet
Brand and version of the device: Wacom Intuos S
System: Windows 10
Running Krita Ver 4.4.3


The Problem
Generally, I have my Wacom Tablet Properties set to use the Tip-side button as the ‘Erase’ function and that would allow me to use the Eraser as long as I held that button down and switch back to brush on release. It’s worked just fine with Sai and Clip Studio (which is using WinTab API) , but not Krita. Whenever I try to use said function I get Krita’s Pan Mode instead as if I pressed Middle-Mouse.

Honestly I’m at my wits end, and will probably lose my sanity without any help solving this. Any help is tremendously appreciated.

Attempted Solutions
Unbinding ‘Pan Mode’ from Middle Mouse in ‘Canvas Input Settings’ does prevent Panning but still doesn’t erase. The cursor just disappears with nothing to replace it.

I’ve tried switching the Tablet API from the default ‘WinTab’ to ‘Windows 8+ Pointer Input Windows Ink’ and while that did bring back the Eraser switch I was looking for, it introduced a whole bunch of issues that make it not worth it.

Looking at the Tablet Tester yields the following info from each Tablet Input API:


I don’t know exactly what the above data means but I thought it could be useful. I feel like WinTab API should be calling the eraser function like the Windows Ink API but it just doesn’t for some reason.

Enabling ‘Use Mouse Events for Right- and Middle-mouse clicks’ did not fix.

Reinstalling Krita did not fix.

Reset+Reinstalling Wacom Tablet Drivers did not fix.

When testing in Krita Version 4.3.0, The Eraser still didn’t work (even with changes listed above), but bizarrely would instead create phantom brush strokes in the Brush History.

Hello and welcome to the forum :slight_smile:

There are quite a few things going on here.

Krita doesn’t have an eraser tool. It uses an ‘eraser mode’ that is toggled on and off by use of the ‘E’ key. In this mode, the brush preset currently being used is forced to paint in Eraser blending mode.
The other way to erase is to use a brush preset that has been specifically desgned to erase (by using the Eraser blending mode). You’ll see about three of these in the Brush Presets docker.

What happens with Sai and Clip Studio when using your stylus is not relevant, especially if you’re concerned with erasing.

Some stylii have an ‘eraser’ tip as well as the normal painting end/tip. This tip, if the stylus has it, is recognised by krita as an ‘Eraser’ but is not used as an eraser, it is used as an alternative/secondary brush preset and can be treated a such and be used to select another type of painting brush preset if you want one. It can also be used to select an erasing brush preset if that is how you want to use it.

The screenshot for Windows Ink mode shows that krita detects an ‘Eraser’.
Is this because you were using the ‘eraser’ end of your stylus or do you have the stylus button configured to make the normal painting tip simulate/emulate an eraser tip?
It’s detecting pressure as you draw and B=1 is the equivalent of continuous mouse left-click. as it needs to be to draw.

When using the WinTab mode, krita is detecting that the stylus is hovering and a B=4 button press (the ‘front’ stylus button), so it will pan the canvas, as it is meant to if that button is mapped to the Space key or a mouse middle-click.

In the Wacom desktop control and setup utility, have you created a separate application profile for krita?
You should so that you can configure the tablet and stylus to work properly with krita.

If you installed a different version of krita then, depending how ‘intelligent’ the tablet driver is, it may be necessary to delete any existing application profile for krita and create a new one.

If you use Wintab in krita then you should disable Windows Ink in the Wacom setup utility, for the krita application profile.

Thank you for the timely reply, and apologies for the late response!

Ah, I think I understand what you mean. Unfortunately for me just forcing the blend mode isn’t what I’m looking for. My only other option there is to set a separate preset, which is a fair workaround.

This! My Pen doesn’t have a Eraser tip but it CAN be configured so that one of the pen buttons tells the painting tip emulate the eraser tip and functions exactly like you describe. And that is usually what I use for all my erasing needs. The below image was supposed to be included in the original post but was omitted for the 2-Image Maximum for new posters XD. But this is my current configuration:


‘Erase’ is the Tablet’s built-in eraser emulation. Which is why I was baffled when the Tablet Tester was recognizing the eraser in Windows Ink mode but not WinTab, and why it would be different, even after unbinding Pan from middle-mouse and spacebar.

And I have created a separate App profile for Krita, as well as deleting and recreating it for good measure each time I changed the API in Krita. My fault for not including that detail in the OP, apologies.

I had not thought of disabling Windows Ink in the Wacom utility earlier, but alas, still no noticeable change. I’ll leave it disabled nonetheless.

Hopefully I’ve provided a clearer picture, if there is still is a solution at all haha

Thank you for the detailed explanation and illustration images.

I have an Intuos Paint (CTH 490K) and I usually use a Linux system but I’ve had a closer look at this on my Windows 10 system.

With the ‘front’ stylus button set to ‘Erase’, krita does not detect the Eraser being used with the Wintab mode.

It does detect the Eraser being used with the Windows Ink mode and I can use it as such, as a secondary/alternative tip that I an use to select an eraser brush preset and use it as an eraser from that point on.
It doesn’t act as a pan mode selector and I can use the keyboard Space key and the mouse middle-click to pan normally.

[Whatever brush preset has been selected with the Eraser tip is remembered for the rest of the session and so the front stylus button can effectively be used as ‘a button that makes it erase’ if an erasing brush preset has been chosen.
That alternative/secondary brush preset is not remembered for the next krita session, which is a bug that has been formally reported for some time now.
However, when krita starts, that alternative/secondary brush preset is the Eraser Circle brush preset so that is suitable for immediate use as an eraser if wanted.]

With the Windows Ink mode in use, using the tablet tester, I get that straight red line between the drawing start and end points but everything works fine.

However, for Windows Ink you said:

What were the issues that gave you problems?

In my Windows system Windows Ink settings, I’ve turned off all options so I wonder if you still have a Windows Ink option enabled somewhere that may be causing problems.

Something I noticed is that you have to close the Wacom setup utility before you try using the stylus in krita otherwise there can be strange and annoying effects.
I also did a full PC restart after making changes, just to be sure.

When enabling Windows Ink mode in Krita, the biggest issues I noticed was when trying to interact with anything like a slider, or the Advanced Color Picker, there would be a decent sized deadzone (~30 pixels, depending on the size of the slider), making it extremely difficulty to make small adjustments. And considering how many sliders there are, I quickly realized how annoying it would become to deal with.

One other issue was choppy pen movement, which I’ve come to notice happens in both WinTab and Ink so I’m not sure if that’s related to the tablet API anymore. Easily avoidable if I just don’t put Krita in Fullscreen.

I’m fairly confident that I’ve disabled all the Ink-related Windows system settings, and disabling Ink in Wacom Utility fixes the deadzone but removes the ability to use Pen Pressure

Additionally, I came across this Post from the AutoDesk forums, which had the same issue albeit with a different program, and tried reseting/restarting my Wacom drivers to no solution, including PC restarts.

EDIT: Added the link that I had forgotten to actually attach. Mostly for posterity.

Oh my I did not know Intuos had it so rough. My old Bambo tablet did not have this kind of issues so I am quite surprised and it seems your missing an eraser tip too.

Also just pressing the E shortcut does not work for you? I feel your not taking advantage of Krita’s eraser fully and want to revert it back to more complicated ways. You can also use a script to change the brush preset to a specific eraser if you want.

Windows is so ‘helpful’ that it makes me want to kick it.
These are Windows Ink and System level related UI interactions that are all part of the ‘service’ in case you just happen to need any help or advice or access to further facilities.

That deadzone is annoying and you can do a double tap touch then slide to avoid it.
I managed to get rid of the annoying white circle and ‘helpful’ menu that appeared if you hold the tip still for too long by following the advice in the last reply here:
Circle appearing when i try to draw and its a lot more laggy than before?

The ‘Remove Windows Circle’ link in that reply may be of use or interest to you.

Along with @EyeOdin , I think you should learn to use the excellent facilities for brush preset changing/swapping that are provided by krita.

Funnily enough, I didn’t have an issue with the white circle.

Ah well, I guess this means there isn’t much else to try and I can’t find much else online either. I pretty much understood from the get-go that there was a big chance I’d have to settle for a workaround, which I’m certainly not opposed to, but it would involve overwriting a few years of muscle memory and a bit of workflow change. Put simply, this was the normal and easiest way all these years XD

This ended up being one of those things that grab your attention and never let go, especially since it felt like it was getting close to being solved each time I found a solution. So apologies if I’ve wasted anyone’s time, and thank you a bunch for taking spending some of it to assist me! I certainly didn’t expect this much help.

1 Like