Failed animation render with layer styles - Help

Let me know if I should report this as a bug or am I missing something?

Krita file here: https://drive.google.com/file/d/1RY2uh8RxcxUAPLAgzFo8G_H7hTl9pTfo/view?usp=sharing

Ref Images:


Is there any way I can get around this or should I just not use layer style effects?

Workaround I use when rendering fails:

  • export as PNG sequences
  • export small number of frames: from frames 0 to 25, then 26 to 50, then 51 to 75, then…
    It’s not ideal but on some export I also some time don’t have the choice.

This method allow, if export fails, to be able to restart from a point without having to regenerate everything

On my side it’s more when I have many filter layers than layer style, but it seems that when you have many thing to calculate on a rendering sometimes Krita start to be lost and failed…

Grum999

1 Like

Yea, I tried all of those. I think layer style effects are just broken sadly, they would be really useful tho. They slow down animation previewing a ton as well.

I didn’t tried yet, but maybe reducing “frame rendering clone limit” to 1 could help to solve the problem? :thinking:

Grum999

1 Like

Thanks @Grum999 you were correct.
Reducing the frame rendering clone limit right down fixed the issue. However, now the render takes an eternity…
I feel there may be an efficiency problem here, not too sure.

My idea about this option is that filter layers and style effects use multithreading for rendering.
And when you start to also use multithreading for rendering frames there’s might be a thing somewhere as many asynchronous process are running.

But I can’t really say what happen.
Maybe @emmetpdx or @eoinoneill that are currently working on animation part have an idea about this.

Another solution could:

  • Save as copy of your original work
  • Merge (or flatten) layers (ie: no more filters layer/special effect, they’re rasterised)
  • Render animation with all cpu

Grum999

1 Like

Merging might be the best option here.
Thanks for the ideas :slight_smile:

Hopefully we can see improvements in Krita 5?

I don’t know, it might depend of complexity of problem I suppose.
Finding/fixing bugs on multi-threading process is not really easy.
But only developers can give an answer to this.

And in all case, you have to open a bug (bugs.kde.org) otherwise it won’t be fixed :sweat_smile:
The most difficult in bug declaration will be to be precise in description…

Grum999

1 Like

And in all case, you have to open a bug (bugs.kde.org) otherwise it won’t be fixed :sweat_smile:`

Is it a bug though?
Or just a limitation, I dunno.
I’ll submit one anyway I suppose since I don’t know.

It might be a bug yes because if rendering is in failure when using multithreading rendering option and not when you limit rendering to 1 thread…
Also considering that without layers filters/styles everything is Ok and not when you have some of them.

But before creating bug, it could be a good thing to made some tests to confirm in which case(s) the problem occurs, and in which case it doesn’t occurs: it could help developer to understand problem.

Grum999

1 Like

Good to know, Will do.

On a short and simple animation, I tried Flattening a layer with Layer Styles on it and it made monochrome echos/shadows of previous and next frames on each frame.

Also, for Pattern Overlay, some patterns are not saved in the .kra file, e.g. Hexacol BW.
I tried changing a pattern and on playback, the previously used pattern was visible on the frame images on the canvas.

I had one crash when rendering a short and simple animation but I haven’t been able to repeat that.

It seems there are a few problems in this area.

If you raise a bug report, please put a link to it here.

Did you test with 4.4.3 or 5.0.0?

Could it be related to this bug ?
I think it’s solved for krita 5 (but currently I didn’t take time to check if it’s solved or not…)

Grum999

It was the latest (May 02) nightly 5.0.0 appimage:

I remember that Transform Mask Flattening bug and there do seem to be similarities.
The Transform Mask Flattening artifacts seem to have been fixed.

Separate observation: There are unfortunate effects when Rotation is part of the Transform Mask. The centre of rotation is the same for all frames, which is not appropriate when frames have different content, as they do in an animation. This may be unavoidable and I haven’t got around to reporting it.

1 Like

If this issue still exists in master please file a bug and we’ll try to handle it as soon as we can.

1 Like

Sorry everyone I forgot to post a link to my report.

https://bugs.kde.org/show_bug.cgi?id=436524

Here’s a bug report for the problems with flattening an animated layer that has layer styles on it:
436721 – Flattening an animated layer with layer effects gives artifacts

I didn’t mention the Pattern Overlay because that seems to be a particular thing with Hexacol which has some other strangeness that I need to look into.

1 Like